Github.com Webhook issues.
Incident Report for amazee.io
Resolved
GitHub reported that the webhook backlog was processed and deliveries now are happening in real-time.
Posted 23 days ago. Oct 23, 2018 - 02:15 CEST
Update
We are still seeing delays with webhooks coming from GitHub.
Posted 23 days ago. Oct 22, 2018 - 23:36 CEST
Update
Github is processing all delayed webhooks currently. This is causing some increased load on systems as many deploys are now running simultaneously, this may cause some builds to take longer than usual.
Posted 23 days ago. Oct 22, 2018 - 21:10 CEST
Update
GitHub has updated that they are beginning to process the webhook backlog, any pushes which would have a push event will start being delivered to us now.
Posted 23 days ago. Oct 22, 2018 - 19:02 CEST
Monitoring
This only affects customer using GitHub.com to deploy to Lagoon.

Github.com currently seems to have issues which they recover from. So far we observe a high delay in webhooks or webhooks entirely beeing paused (as noted on the incident report of github https://blog.github.com/2018-10-21-october21-incident-report/ )
Posted 23 days ago. Oct 22, 2018 - 15:27 CEST
This incident affected: General (Deployment Infrastructure).