Let's Encrypt Certificate creation issues
Incident Report for amazee.io
Resolved
This incident has been resolved.
Posted Jun 02, 2020 - 02:36 CEST
Investigating
We're currently investigating issues with creating Let's Encrypt Certificates on CH1-Lagoon

Customers with valid certificates are not impacted only newly issued certificates seem to take longer than usual to load the certificate onto the route. If you see immediate issues please get in touch with Support.
Posted May 28, 2020 - 13:13 CEST
This incident affected: Switzerland (ch1.lagoon).