A small percentage of deployments with complex or invalid docker-compose.yml files were affected due to an improvement introduced to Lagoon build-deploy tool in the latest release. After the initial investigations, we downgraded the Lagoon build-deploy image to the previous version asap to fix the issues for now, until a more permanent solution is introduced in an upcoming lagoon release. We will be conducting extensive testing for the unforeseen docker-compose.yml configurations identified through this issue to determine a pathway to avoid similar incidents in the future.
Posted Jun 10, 2022 - 06:10 UTC
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Jun 10, 2022 - 00:58 UTC
Identified
The issue has been identified and a fix is being implemented.
Posted Jun 10, 2022 - 00:26 UTC
Investigating
We are aware of some Lagoon deployments failing due to specific configurations in the docker-compose.yml files and also some issues with generating new routes in the environments. This is impacting only the projects with some specific configurations in docker-compose files so not affecting all deployments. We are looking into this to identify the exact causes of the failures.
Posted Jun 09, 2022 - 23:43 UTC
This incident affected: General (Deployment Infrastructure).