Degraded performance on CH1
Incident Report for amazee.io
Resolved
This incident has been resolved.
Posted Sep 15, 2020 - 12:55 UTC
Investigating
We are currently investigating this issue.
Posted Sep 15, 2020 - 12:49 UTC
This incident affected: Switzerland (ch1.lagoon).