Lagoon tasks error out
Incident Report for amazee.io
Resolved
We've resolved the issue now for the majority of users. A previous update identified a workaround in the unlikely event that you may still experience the issue.

Reach out to support if you do encounter the error and aren't quite sure how to resolve it.
Posted Apr 05, 2024 - 00:57 UTC
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Apr 04, 2024 - 19:37 UTC
Identified
After release of Lagoon 2.18 triggering tasks that require cli pod from UI will result this error `Environment has no service cli`
A short term fix is to trigger a deployment OR run this api mutation for the environment that the task is broken on
mutation {
addOrUpdateEnvironmentService(input: {
environment:
name: "cli"
type: "cli"
}) {
id
name
type
}
}
Lagoon team is working on permanent fix
Posted Apr 04, 2024 - 18:30 UTC
This incident affected: General (Lagoon Dashboard).