Deployments failing due to upstream issues on git.drupal.org / github.com / bitbucket.org
Incident Report for amazee.io
Resolved
We don't see any issues with pulling from git.drupal.org / github.com / bitbucket.org anymore.
Posted Jul 26, 2016 - 11:49 UTC
Update
GitHub and Bitbucket work without any issues. For the Hosting zones located in areas which reported issues with connecting to git.drupal.org we put a workaround in place to route traffic which had positive impact on deployments.
We are working together with the Drupal Association to work around this issue and will continue to monitor the situation.
Posted Jul 19, 2016 - 10:51 UTC
Update
GitHub and BitBucket have reported that they shifted their routes away from Level3 and onto NTT. While this is a longer route to their services from European originations, it is proving to be more stable at this time.
Posted Jul 18, 2016 - 20:48 UTC
Update
We just got a reply of the engineers at Github. The issue is bound to Europe where customers connect via the Internet backbone provider Level 3. The engineers at GitHub work together with Level 3 to solve those connection issues. Our engineers will continue to monitor the situation and update the status accordingly.
Posted Jul 18, 2016 - 16:18 UTC
Monitoring
The issue with git.drupal.org has been solved (https://www.drupal.org/node/2767723#comment-11413161) we're continuing to monitor the situation.
Posted Jul 18, 2016 - 13:13 UTC
Identified
We're seeing an elevated rate of failing deployments if they are pulling submodules from git.drupal.org.
We raised the issue with the Drupal infrastructure team (see https://www.drupal.org/node/2767723). As soon as the connection issues have been solved we will update this issue accordingly.
Posted Jul 18, 2016 - 12:24 UTC
This incident affected: General (Deployment Infrastructure).