ch1-lagoon - Unstabilities
Incident Report for amazee.io
Resolved
This incident has been resolved.
Posted 3 months ago. Dec 19, 2018 - 16:03 CET
Investigating
We are currently investigating this issue.
Posted 3 months ago. Dec 19, 2018 - 15:47 CET
This incident affected: Switzerland (ch1.lagoon).